Elevated API Errors
Incident Report for TaskRabbit
Resolved
This incident has been resolved.
Posted Oct 17, 2019 - 13:39 PDT
Investigating
Our automated systems have detected a problem. Our engineers have been notified and we are looking into it.
Posted Oct 17, 2019 - 13:39 PDT