Elevated API Errors
Incident Report for TaskRabbit
Resolved
This incident has been resolved.
Posted 3 months ago. Dec 22, 2018 - 09:14 PST
Investigating
Our automated systems have detected a problem. Our engineers have been notified and we are looking into it.
Posted 3 months ago. Dec 22, 2018 - 08:16 PST