Elevated API Errors
Incident Report for TaskRabbit
Resolved
This incident has been resolved.
Posted 16 days ago. Sep 01, 2019 - 21:28 PDT
Investigating
Our automated systems have detected a problem. Our engineers have been notified and we are looking into it.
Posted 16 days ago. Sep 01, 2019 - 21:26 PDT