Tasker Registration Flow Issues
Incident Report for TaskRabbit
Resolved
This incident has been resolved and Tasker registration should be working normally again.
Posted Aug 15, 2019 - 16:01 PDT
Investigating
Our engineers are currently investigating an issue with some Tasker verifications and registrations . We will update here as we understand more.
Posted Aug 15, 2019 - 13:58 PDT
This incident affected: www.TaskRabbit.com, www.TaskRabbit.co.uk, and www.TaskRabbit.ca.