Elevated API Errors
Incident Report for TaskRabbit
Resolved
This incident has been resolved.
Posted 19 days ago. Aug 30, 2019 - 06:00 PDT
Investigating
Our automated systems have detected a problem. Our engineers have been notified and we are looking into it.
Posted 19 days ago. Aug 30, 2019 - 05:58 PDT