Elevated API Errors
Incident Report for TaskRabbit
Resolved
This incident has been resolved.
Posted 20 days ago. Aug 28, 2019 - 11:45 PDT
Investigating
Our automated systems have detected a problem. Our engineers have been notified and we are looking into it.
Posted 20 days ago. Aug 28, 2019 - 11:43 PDT