Elevated API Errors
Incident Report for TaskRabbit
Resolved
This incident has been resolved.
Posted 2 months ago. Jan 07, 2019 - 19:13 PST
Investigating
Our automated systems have detected a problem. Our engineers have been notified and we are looking into it.
Posted 2 months ago. Jan 07, 2019 - 15:35 PST