Elevated API Errors
Incident Report for TaskRabbit
Resolved
This incident has been resolved.
Posted about 1 month ago. Oct 16, 2018 - 01:47 PDT
Investigating
Our automated systems have detected a problem. Our engineers have been notified and we are looking into it.
Posted about 1 month ago. Oct 15, 2018 - 22:38 PDT
This incident affected: www.TaskRabbit.com.