Elevated API Errors
Incident Report for TaskRabbit
Resolved
Small glitch resolved
Posted 3 months ago. Aug 29, 2018 - 17:39 PDT
Investigating
Our automated systems have detected a problem. Our engineers have been notified and we are looking into it.
Posted 3 months ago. Aug 29, 2018 - 17:35 PDT