Elevated API Errors
Incident Report for TaskRabbit
Resolved
This incident has been resolved.
Posted about 1 month ago. Dec 14, 2018 - 10:44 PST
Investigating
Our automated systems have detected a problem. Our engineers have been notified and we are looking into it.
Posted about 1 month ago. Dec 13, 2018 - 15:48 PST