Elevated API Errors
Incident Report for TaskRabbit
Resolved
Small glitch in the system, back to normal.
Posted May 08, 2018 - 11:03 PDT
Investigating
Our automated systems have detected a problem. Our engineers have been notified and we are looking into it.
Posted Apr 16, 2018 - 08:42 PDT