Elevated API Errors
Incident Report for TaskRabbit
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 27, 2018 - 08:36 PDT
Investigating
Our automated systems have detected a problem. Our engineers have been notified and we are looking into it.
Posted 3 months ago. Aug 26, 2018 - 13:43 PDT