Elevated API Errors
Incident Report for TaskRabbit
Resolved
This incident has been resolved.
Posted 15 days ago. Nov 01, 2018 - 09:47 PDT
Investigating
Our automated systems have detected a problem. Our engineers have been notified and we are looking into it.
Posted 15 days ago. Nov 01, 2018 - 06:40 PDT