Elevated API Errors
Incident Report for TaskRabbit
Resolved
This incident has been resolved.
Posted about 2 months ago. Sep 28, 2018 - 02:33 PDT
Investigating
Our automated systems have detected a problem. Our engineers have been notified and we are looking into it.
Posted about 2 months ago. Sep 28, 2018 - 02:21 PDT