Elevated API Errors
Incident Report for TaskRabbit
Resolved
This incident has been resolved.
Posted 11 days ago. Jan 08, 2019 - 07:57 PST
Investigating
Our automated systems have detected a problem. Our engineers have been notified and we are looking into it.
Posted 11 days ago. Jan 08, 2019 - 07:55 PST