Elevated API Errors
Incident Report for TaskRabbit
Resolved
This incident has been resolved.
Posted 4 days ago. Dec 06, 2018 - 14:37 PST
Investigating
Our automated systems have detected a problem. Our engineers have been notified and we are looking into it.
Posted 4 days ago. Dec 06, 2018 - 11:28 PST