Elevated API Errors
Incident Report for TaskRabbit
Resolved
small glitch in the system, resolved.
Posted 23 days ago. Nov 17, 2018 - 17:36 PST
Investigating
Our automated systems have detected a problem. Our engineers have been notified and we are looking into it.
Posted 23 days ago. Nov 17, 2018 - 14:22 PST