Elevated API Errors
Incident Report for TaskRabbit
Resolved
Small glitch resolved
Posted 28 days ago. Nov 12, 2018 - 21:33 PST
Investigating
Our automated systems have detected a problem. Our engineers have been notified and we are looking into it.
Posted 28 days ago. Nov 12, 2018 - 15:05 PST